1.19.7:

2011-07-12  Murray Cumming  <murrayc@murrayc.com>

	ImageGlom: Saving is now mostly async.

	* glom/utility_widgets/dialog_image_save_progress.[h|cc]: Doing the actual 
	writing in callbacks, like in the loader.
	* glom/utility_widgets/imageglom.cc: Show the dialog, so we can use the 
	idle callbacks, and give user feedback.

2011-07-12  Murray Cumming  <murrayc@murrayc.com>

	ImageGlom: Allow the user to choose any file.

	* glom/utility_widgets/imageglom.cc: However, we are still restricted to 
	what GdkPixbuf can load.

2011-07-12  Murray Cumming  <murrayc@murrayc.com>

	ImageGlom: Do not transform to PNG output when saving.

	* glom/utility_widgets/dialog_image_save_progress.[h|cc]: Replace set_pixbuf() 
	with set_image_data().
	save(): Save the original data, instead of saving the data from the pixbuf.
	* glom/utility_widgets/imageglom.cc: Adapt.
	This means, for instance, that if the user loads the a JPG in then they will 
	get exactly the same JPG out.

2011-07-12  Murray Cumming  <murrayc@murrayc.com>

	Some minor signed type corrections.

	* glom/libglom/connectionpool_backends/postgres.cc:
	* glom/xsl_utils.cc: Gio::FileOutputStream::write() returns a gssize, not a 
	gsize.

2011-07-12  Murray Cumming  <murrayc@murrayc.com>

	ImageGlom: Size request corrections.

	* glom/utility_widgets/imageglom.cc: init(): Remove the set_size_request() 
	call which does not seem necessary.
	Do not call set_image(original) after scale(), because scale() does that, 
	setting the scaled image.
	This avoids the GtkImage being huge, because GtkImage re-requests the 
	bigger size again when the original is put in it.
	This is still not ideal. It would be nicer if we could just say "do not 
	make the window bigger than the screen, or do not make this make the 
	window bigger."

2011-07-12  Murray Cumming  <murrayc@murrayc.com>

	ImageGlom: Use AppInfo instead of gtk_show_uri() for Open.

	* glom/utility_widgets/imageglom.cc: For the case that we have no AppInfo
	(not Open With), use the static AppInfo method, for consistency.
	This might work on Win32 too.

2011-07-12  Murray Cumming  <murrayc@murrayc.com>

	Image fields: Add Open, Open With, and Save context menu items.

	* glom/utility_widgets/dialog_image_save_progress.[h|cc]:
	* ui/operator/dialog_image_save_progress.glade:
	Added a progress dialog to do image saving, though it does not yet do 
	async saving so the dialog is never shown.
	* Makefile.am:
	* Makefile_glom.am:
	* po/POTFILES.in: Mention the new files.
  * glom/utility_widgets/imageglom.[h|cc]: Add the new context menu items,
  using a temporary file for the Open and Open With features.
  Open With uses AppChooserDialog to offer a choice to the user.
  Bug #630057

2011-07-11  Murray Cumming  <murrayc@murrayc.com>

	Rename Dialog_Image_Progress to DialogImageLoadProgress

	* glom/utility_widgets/dialog_image_progress.[h|cc]:
	Rename to 
	* glom/utility_widgets/dialog_image_load_progress.[h|cc]:
	* tests/test_glade_derived_instantiation.cc:
	* ui/operator/dialog_image_progress.glade: Rename to
	* ui/operator/dialog_image_load_progress.glade:
	* glom/utility_widgets/imageglom.h:
	* Makefile.am:
	* Makefile_glom.am:
	* po/POTFILES.in: Adapt.
	
	I can then add a new dialog for saving.

2011-07-11  Ben Konrath  <ben@bagu.org>

	Add PACKAGE_TARNAME variable to pkg-config file.

	This is needed for the @docdir@ expansion used in the exampledir
	variable.

	* glom/libglom/glom.pc.in:

2011-07-11  Ben Konrath  <ben@bagu.org>

	Add exampledir variable to pkg-config file.

	* glom/libglom/glom.pc.in:
	Bug #654384

2011-07-11  Murray Cumming  <murrayc@murrayc.com>

	Add translator comments.

	* glom/libglom/data_structure/field.cc:
	* glom/libglom/data_structure/layout/*.c:
	* glom/mode_data/box_data_list.cc:
	* glom/mode_data/box_data_list.h:
	* glom/mode_data/box_data_manyrecords.cc:
	* glom/mode_data/notebook_data.cc:
	* ui/developer/dialog_script_library.glade: Add translator comments.
	Bug #638996 (Joe Hansen)

2011-07-08  Murray Cumming  <murrayc@murrayc.com>

	Related Records: Show enough records.

	* glom/mode_data/db_adddel/db_adddel.[h|cc]: Added set_height_rows(), so 
	we can set the minimum size based on the number of rows, though this 
	currently hard-codes a size for the non-rows part of the GtkTreeView, such 
	as the column headers.
	* glom/mode_data/box_data_portal.cc:
	* glom/mode_data/box_data_list_related.cc: Constructors: Remove unnecessary 
	calls to set_size_request().
	Call set_height_rows() instead.

  The related records Gtk::TreeViews probably became too small since the port to 
  gtkmm3. We now need to use Gtk::ScrolledArea::set_min_content_height().
  
  However, the number of rows should probably be something for the layout to 
  specify per portal.
	
2011-07-08  Murray Cumming  <murrayc@murrayc.com>

	Minor int->guint change.

	* glom/mode_data/db_adddel/db_adddel.[h|cc]: get_fixed_cell_height(): 
	Return a guint instead of an int.

2011-07-08  Murray Cumming  <murrayc@murrayc.com>

	Details: Do not navigate past the last row.

	* glom/mode_data/datawidget/treemodel_db.[h|cc]: get_last_row(): 
	Document that this never returns the placeholder row, and make sure that it 
	does not. There was a typo that --ed the wrong variable.
	* glom/mode_data/db_adddel/db_adddel.[h|cc]: get_last_row(): 
	Document that this never returns the placeholder row.
	get_is_placeholder_row(): Remove an illogical call to is_last_row().
	get_count(): Remove an illogical check to see whether the last row is the 
	placeholder row.
	* glom/utility_widgets/adddel/adddel.h: get_last_row(): Document that this 
  similarly-APIed widget has different behaviour.
  
  This stops the user from being taken to an empty record when clicking Last, 
  or when clicking Next to the end.
  Bug #526115 comment #25 (Michael Hasselmann)

2011-07-08  Murray Cumming  <murrayc@murrayc.com>

	DbAddDel: Remove unnecessary virtual keywords. 

	* glom/mode_data/db_adddel/db_adddel.h: These methods are not meant to 
	be overridden by anything.